Config file 39etcportagepackage keywords39 needs updating

You need to commit your outstanding changes, or stash them, pull/rebase/merge/whatever you're doing to update, and unstash It's not actually the pull - it's the merge that's part of the pull.You'll see the same error if you try to merge a local branch with the same problem, and I think other mergey operations (apply, stash apply...) print similar errors if not the same one.[git reset --hard HEAD] worked for me. /usr/local/portage does not seem to have a valid PORTDIR structure. There is an ebuild this app, but neither has the layman and I trust more in your repository, you could create on your own?You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked. You must upgrade to a newer version of portage before EAPI masked packages can be installed. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]) required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/py-1.4.30:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sys-apps/kmod-19:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)? For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by "dev-python/requests-2.9.1-r2::gentoo" [ebuild]) (dependency required by "dev-python/ssl-fetch-0.4::gentoo" [ebuild]) (dependency required by "app-portage/layman-2.3.0-r1::gentoo" [ebuild]) (dependency required by "@selected" [set]) (dependency required by "@world" [argument]) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. The following USE changes are necessary to proceed: (see "package.use" in the portage(5) man page for more details) # required by dev-qt/qtcore-5.5.1-r1::gentoo # required by dev-qt/qtconcurrent-5.5.1::gentoo # required by net-p2p/qbittorrent-3.3.3::gentoo[qt5] # required by @selected # required by @world (argument) =dev-libs/libpcre-8.38 pcre16 # required by dev-qt/qtgui-5.5.1::gentoo[xcb] # required by dev-qt/qtwidgets-5.5.1-r1::gentoo # required by dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo[X,qt5] # required by media-video/smplayer-15.11.0::gentoo[qt4] # required by @selected # required by @world (argument) =x11-libs/libxcb-1.11.1 xkb # required by dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo # required by media-video/smplayer-15.11.0::gentoo[qt4] # required by @selected # required by @world (argument) =dev-qt/qtsingleapplication-2.6.1_p20150629 qt5 Would you like to add these changes to your config files? * IMPORTANT: 3 news items need reading for repository 'gentoo'. * IMPORTANT: config file '/etc/portage/pac kage.use' needs updating. WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: sys-apps/portage:0 (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge) conflicts with sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (app-portage/layman-2.3.0-r1:0/0::gentoo, installed) sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed) * IMPORTANT: 3 news items need reading for repository 'gentoo'. * IMPORTANT: config file '/etc/portage/package.use' needs updating. [ebuild NS ] dev-lang/python-3.4.3-r7 [2.7.10-r2, 3.3.5-r2] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst" [ebuild U ] dev-lang/python-exec-2.1 [2.0.2] [ebuild U ] app-eselect/eselect-python-20151117-r2 [20140125] [blocks b ] =app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge) app-eselect/eselect-python required by (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed) app-eselect/eselect-python required by (dev-lang/python-2.7.10-r2:2.7/2.7::gentoo, installed) (dev-lang/python-2.7.10-r2:2.7/2.7::gentoo, installed) pulled in by =dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/util-linux-2.27.1:0/0::gentoo, installed) For more information about Blocked Packages, please refer to the following section of the Gentoo Linux x86 Handbook (architecture is irrelevant): https://wiki.gentoo.org/wiki/Handbook: X86/Working/Portage#Blocked_packages emerge -pv1 =app-eselect/eselect-python-20140125 python:2.7 python:3.3 These are the packages that would be merged, in order: Calculating dependencies... [ebuild U ] dev-lang/python-exec-2.1:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5) (-jython2_5%*)" 81 Ki B [ebuild U ] dev-lang/python-2.7.11-r2:2.7::gentoo [2.7.10-r2:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst" 12.003 Ki B [ebuild U ] app-eselect/eselect-python-20151117-r2::gentoo [20140125::gentoo] 62 Ki B [ebuild U ] dev-lang/python-3.3.5-r7:3.3/3.3m::gentoo [3.3.5-r2:3.3/3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened -libressl -tk -wininst" 0 Ki B [ebuild R ] app-eselect/eselect-python-20140125::gentoo 71 Ki B [blocks B ] =app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.3.5-r7:3.3/3.3m::gentoo, ebuild scheduled for merge) ^^ ^^^^^^^^^^^ (and 1 more with the same problem) It may be possible to solve this problem by using to prevent one of those packages from being selected.

There are 3 good guides that helped me out: I was using a 64bit version so I grabbed the ISO.I can't for the life of me find any decent explanation of the "[file]: needs update" message that git sometimes spits out from time to time.Even the official git FAQ has explaining this marked as a TODO.So, I have stumbled over a page here ,which basically suggest that the installation was problematic. One of the following packages is required to complete your request: - dev-lang/php-5.3.9::gentoo (Change USE: pdo) (dependency required by "www-apps/drupal-7.12" [ebuild]) (dependency required by "drupal" [argument]) sudo emerge -av drupal These are the packages that would be merged, in order: Calculating dependencies... emerge: there are no ebuilds built with USE flags to satisfy "=dev-lang/php-5.3*[apache2]". One of the following packages is required to complete your request: - dev-lang/php-5.3.9::gentoo (Change USE: apache2) (dependency required by "virtual/httpd-php-5.3" [ebuild]) (dependency required by "www-apps/drupal-7.12" [ebuild]) (dependency required by "drupal" [argument]) sudo emerge -av drupal These are the packages that would be merged, in order: Calculating dependencies... [ebuild N ] dev-libs/oniguruma-5.9.2 528 k B [ebuild N ] app-admin/webapp-config-1.50.16-r1 102 k B [ebuild N ] dev-libs/libmcrypt-2.5.8-r2 1,304 k B [ebuild N ] app-admin/eselect-php-0.6.2 2 k B [ebuild N ] media-libs/t1lib-5.1.2 USE="X -doc -static-libs" 1,829 k B [ebuild N ] virtual/httpd-cgi-0 0 k B [ebuild N ] app-text/aspell-0.60.6.1 USE="nls" LINGUAS="-af -be -bg -br -ca -cs -cy -da -de -el -en -eo -es -et -fi -fo -fr -ga -gl -he -hr -is -it -la -lt -nl -no -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -uk -vi" 1,835 k B [ebuild N ] app-dicts/aspell-en-6.0.0 179 k B [ebuild N ] dev-lang/php-5.3.9 USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap mysql mysqli nls pdo phar posix readline session simplexml spell ssl tokenizer truetype unicode xml zlib -bcmath -calendar -cdb -cgi -cjk -curl -curlwrappers -debug -doc -embed -enchant -firebird -flatfile -fpm -frontbase -ftp -gmp -imap -inifile -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mhash -mssql -mysqlnd -oci8-instant-client -odbc -pcntl -pic -postgres -qdbm -recode -sharedmem -snmp -soap -sockets -sqlite -sqlite3 -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 11,438 k B [ebuild N ] virtual/httpd-php-5.3 0 k B [ebuild N ~] www-apps/drupal-7.12 USE="mysql -postgres -sqlite -vhosts" 3,017 k B Total: 11 packages (11 new), Size of downloads: 20,229 k B Would you like to merge these packages?So I decided to plunge into it to have a crack on it. All ebuilds that could satisfy "drupal" have been masked. One of the following masked packages is required to complete your request: dev-lang/php pdo gd mysql mysqli xml - www-apps/drupal-7.12::gentoo (masked by: ~x86 keyword) - www-apps/drupal-7.10::gentoo (masked by: ~x86 keyword) - www-apps/drupal-6.24::gentoo (masked by: ~x86 keyword) - www-apps/drupal-6.22::gentoo (masked by: ~x86 keyword) - www-apps/drupal-5.23::gentoo (masked by: ~x86 keyword) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. [Yes/No] y On the process to get it into my system I have added it keywords file and made some flags to add with the php .However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously.

559

Leave a Reply